It looks good to me - and better than the documentation you usually see on public forums!
It would be a good idea to add a comment for GPS, what is it. It's a named location and the docs should say that. Avoid implementation details, so
name could be described as /** The name of the location.*/ and
location as /** The coords of the location.*/. In other words we don't need to be told that thecoords consist of a coule of doubles, or that the name will be assigned...
Consider "self documentation" - NamedLocation is a better name for the class than GPS.
Personally I don't bother with "param" if it abundantly clear from the rest of the documentation. I'm partial to "given" in this respect and would settle for
/** Constructs a GPS with a given name and coords. */
public GPS(String name, GpsCoordinates coords) {
this.name = name;
location = coords;
}
(my brace placement like indenting the javadoc comments is ideosyncratic. There are no rules... Other than those imposed by your boss or teacher...)
Consider documenting main in the driver. This can be handy as a "reminder to self" about how the thing is supposed to be run.
---
As a side point: don't be afraid of posting javadocced code on a forum like this. Noone can (reasonably) begrudge the bandwidth if the comments are to the piunt. And they go a long, long way in communicating how you are thinking and what you intend.
--- Update ---
Sorry for the typos ;(. Using a phone. Over a liquid lunch.
Listen to Norm - he's the real thing: I'm just an amateur who likes to know 6 monthes later what I meant 6 monthes before...