I'd recommend that you toss that code and start over. Its {}s are completely messed up.
When entering code make sure that the { that starts a method definition has a } to go with it.
When coding an if statement, make sure that the { that starts enclosing the code in the if has a } to go with it.
Statements withing {}s should be indented, not in the same column as the { enclosing them.
These are very basic things that will make the code readable. Unformatted code is hard to read.
Here's your code with some formatting and comments:
public ArrayList<Journal>getJournalList(String empName)
{
JournalCollection result = new Journalcollection();
for (Journal journal : journals)
} // end getJournalList()
{ //????????? What does this enclose? It's } is missing
if (journal.match(empName)boolean match(String empName);
{
return circulationList.contains(empName);
}
// Following two statements don't below with any other code????
{
result.addJournal(journal);
}
{
return result;
}